09027770800
021-22944644
[email protected]
۲۷ آبان ۱۳۹۶

بکاپ میکروتیک اتوماتیک و ایمیل آن در میکروتیک

/
نوشته شده توسط
/
دیدگاه0

بکاپ میکروتیک

بکاپ گیری اتوماتیک و ایمیل آن در میکروتیک

یکی از مشکلاتی که بیشتر مدیران شبکه با آن دست و پنجه نرم می کنند، فرایند تهیه فایل پشتیبان یا بکاپ از تنظیمات روتر و سوییچ ها می باشد، که در مواردی ممکن است با سوختن روتر یا سوییچ و نداشتن یک فایل پشتیبان خوب و به روز ، کار مضاعف زیادی را تحمیل واحد فناوری اطلاعات سازمان کند.
از جمله قابلیت های کارآمد روتر میکروتیک می توانیم به ارسال فایل پشتیبان به صورت هدفمند به ایمیل مدیر شبکه اشاره کرد.بکاپ میکروتیک

در این مطلب ما برای شما بکاپ میکروتیک را آموزش میدهیم به این صورت که شما بکاپ میکروتیک را ابتدا ایجاد میکنید و سپس آن را به ایمیل خودتان ارسال میکنید.
برای این کار کد زیر را در ترمینال وارد می کنیم

/system script add name=ebackup source={/system backup save name=([/system identity get name] . "-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]); \
/tool e-mail send to="[email protected]" subject=([/system identity get name] . " Backup " . \
[/system clock get date]) file=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup"); :delay 10; \
/file rem [/file find name=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup")]; \
:log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date])}

تحلیل دستورات

• در تحلیل این کد باید بگوییم که در خط اول کد نام و یا همان identity که در مسیر system/identity را تنظیم کرده ایم نسخه پشتیبان میگیرد.
• در مرحله بعد ما زمان روتر را استخراح می کنیم.
• در قدم بعدی مشخص می کنیم که این فایل به کدام ایمیل ارسال شود.
• در مرحله Delay روتر ۱۰ ثانیه صبر می کند تا فایل ارسال شود . سپس فایل قبلی را به جهت نگهداری بهینه از فضای روتر نگه می دارد.
• و در آخرین خط با فرمان log در روتر لاگ می اندازد تا مدیر شبکه بداند که این عمل با موفقیت انجام شده است.

حتما بخوانید  دوره MTCRE مخصوص شاغلین

کافیست در دستور بالا به جای [email protected] ایمیل خود را وارد نمایید .لازم به ذکر است قبل از انجام این دستور در زیر منوی tools/menu پیکربندی ایمیل خود را انجام دهید. برای پیکربندی ایمیل خود نیز می توانید از نمونه دستور زیر در ترمینال استفاده کنید .

/tool e-mail
set address=173.194.77.108
set port=587
set [email protected]
set user=myuser
set password=mypassword

دانلود دانلود مقاله بصورت PDF

موفق و سربلند باشید.
نویسنده شاهین فیضی.

ارسال پاسخ

18 − 8 =